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About this workbook 
Welcome to this Infor Education course! We hope you will find this learning experience enjoyable and 
instructive. This Training Workbook is designed to support the following forms of learning: 

• Classroom instructor-led training 
• Virtual instructor-led training 
• Self-directed learning 

This Training Workbook is not intended for use as a product user guide. 

Activity data 
You will be asked to complete some practice exercises during this course. Step-by-step instructions are 
provided in this guide to assist you with completing the exercises. Where necessary, data columns are 
included for your reference. 

Your instructor will provide more information on systems used in class, including server addresses, login 
IDs, and passwords. 

Self-directed learning 
If you are taking this course as self-directed learning, there may be instructor-recorded presentations 
and/or simulations available to assist you.  

If instructor-recorded presentations are available, a hyperlink to the recording will be included on the first 
page of each corresponding Lesson. 

If simulations are available, the demos and exercises throughout this Training Workbook will include 
hyperlinks that allow you to view and/or practice the execution of the demo or exercise in a simulated 
training environment. 

Learning Libraries 
Learning Libraries in Infor Campus include learning materials that are available to you online, anytime, 
anywhere. These materials can supplement instructor-led training, providing you with additional learning 
resources to support your day-to-day business tasks and activities.  

Please note that if you accessed this Training Workbook directly via a Learning Library, you will not have 
access to the Infor Education Training Environment that is provided with all instructor-led and most self-
directed learning course versions, as referenced above. Therefore, you will not be able to practice the 
exercises in the specific Training Environment for which the exercises in this Training Workbook were 
written.  
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Symbols used in this workbook 
 

 

Hands-on exercise 
(“Exercise”) 

 
Your notes 

 
Question 

 

Instructor demonstration 
(“Demo”)  

Important note 
 

Answer 

 

Can be used for either 
(“Scenario” or “Discussion”) 

 
Critical note 

 
Task simulation 

 
For your reference 

 
 

 
 

 

 



 

Infor CRM: Advanced Analytics v3.0 Training Workbook 7 
   

  © 2018 Infor Education. All rights reserved. No part of this Training Workbook may be reproduced or transmitted in any form, without written permission. 

Course overview 
Estimated time 
.25 hours 

Learning objectives 
Upon completion of this course, you’ll be able to: 

• Install and configure a working TIBCO Spotfire environment. 
• Install and configure Infor CRM Advanced Analytics to third-party components. 
• Add data to Spotfire from a custom Infor CRM table. 
• Add data to Spotfire from a third-party table. 
• Create a parallel model for customization. 
• Design visualizations that can limit data based on other visualizations. 
• Design visualizations that use custom expressions and bookmarks. 
• Apply Infor CRM security to a custom dashboard. 
• Add a dashboard to Infor CRM Windows and Web Client. 

Topics 
• Course description and agenda 
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Course description and agenda 
This course covers how to install Infor CRM Advanced Analytics (ICAA), how to install TIBCO Spotfire 
and how to customize ICAA. The recommended agenda suggests completing Lessons 1-3 on Day 1 and 
Lesson 4 on Day 2. You are welcome to work ahead if you have time. This training is for Advanced 
Analytics v3.x. 

Course duration 
16 hours 

Prerequisite knowledge 
To optimize your learning experience, Infor recommends you have the following knowledge prior to 
attending this course: 

• Infor CRM Implementing 
• Infor CRM Development 

Audience 
• Business Consultant  
• Technical Consultant  
• Support 
• System Administrator  

System requirements 
Infor CRM Training Environment 

Reference materials 
Infor CRM reference materials are available from the following locations:  

• Infor CRM Help menu 
• Infor Xtreme® 

Course agenda 
The agenda below details the contents of this course, including lesson-level learning objectives and 
supporting objectives. 
 

Lesson Lesson title Learning objectives Day 

Course overview Review course expectations 1 

1 Implementation overview • ICAA components 

• System diagram 

1 
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Lesson Lesson title Learning objectives Day 

• Single sign-on authentication 

• Data security 

• Installation summary 

2 Preparing the Infor CRM 
environment 

• Unpack the Infor CRM Advanced 
Analytics zip file. 

• Install the add-on license 

1 

3 TIBCO Spotfire installation • Install TIBCO Spotfire 1 

4 Infor CRM Advanced Analytics 
customization 

• Customize Infor CRM Advanced 
Analytics 

• Customization Best Practices 

1-2 

Course summary Debrief course. 2 

 

Appendices 
This section contains information that is not part of the instructional content of this course, but provides 
additional related reference information. 
 

Appendix Appendix title Content description 

Appendix A Learner user accounts This appendix provides a reference for 
student login credentials. 

Appendix B Installing the Spotfire Web Player on a 
different computer from the Spotfire 
Server 

Install TIBCO Spotfire Web Player on a 
different computer from the Spotfire 
Server. 
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Lesson 1: Implementation overview 
Estimated time 
2 hours 

Learning objectives 
The Infor CRM Advanced Analytics installation has been prepared on your workstation. Use the TIBCO 
Spotfire Professional Client to edit or create new analyses and publish them to other Infor CRM users. 

In this lesson, you will: 

• List the components of Infor CRM Advanced Analytics. 
• Recognize the relationships between Infor CRM and TIBCO Spotfire. 
• Recall how Single sign-on is accomplished in Infor CRM Advanced Analytics. 
• Explain how Data Security is handled within Infor CRM Advanced Analytics. 

Topics 
• ICAA components 
• System diagram 
• Single sign-on authentication 
• Data security 
• Installation summary 
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ICAA components 
The components below are used in an Infor CRM Advanced Analytics implementation. 

• Analysis Support Bundle: This bundle installs new Infor CRM dashboards and supporting 
plugins. It also creates new tables in the Infor CRM database. These components allow ICAA to 
be embedded within the Infor CRM application framework. 

• Web Analytics Support Bundle: This bundle installs the Advanced Analytics Navigation bar 
and dashboards. 

• Infor CRM Database Server: This is the core data source for the ICAA application. 
• Spotfire Web Player: This client is embedded into Infor CRM. It is a zero-footprint, thin client that 

allows users to analyze data by interacting with the dashboard to drill, pivot, filter, and manipulate 
the visualizations included in the dashboard analysis. 

• Spotfire Professional Client: This client allows administrators to edit or create new analyses 
and publish them to other Advanced Analytics users. 
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System diagram 
ICAA content is built on an information model in the TIBCO Spotfire platform. The information model is 
used to map data from the data sources to Advanced Analytics. It’s also used to create calculated fields, 
transform data, and perform other advanced tasks. Information links within the information model are used 
to create dashboards and other analysis. 

 
Information Model 
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Single sign-on authentication 
ICAA is configured for single sign-on using impersonation with custom authentication. Spotfire Web 
Player uses Infor CRM user credentials to gain access to data the user can access. 

Your administrator gives users access to Advanced Analytics dashboards by adding the Advanced 
Analytics role to the user in Infor CRM Web Administrator and opening the Spotfire Professional Client to 
synchronize users automatically. Your administrator can remove access to the Advanced Analytics 
dashboards for any user by removing their Advanced Analytics role and synchronizing in the Spotfire 
Professional Client. 
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Data security 
ICAA enforces the data security defined in Infor CRM. Note: Users cannot bypass data security. 

• Users can only access data they see in Infor CRM.  
• Dashboards cannot report on data the user does not have access to.  

ICAA uses role security in both Infor CRM and Spotfire. In Infor CRM, roles grant access to the 
dashboards in the navigation bar. In Spotfire, roles grant access to Spotfire Professional Client or Web 
Player. Note: Users can have different levels of access to Spotfire Professional Client. For example, users 
can be restricted from performing certain actions such as editing the information model. New users added 
to Infor CRM are automatically added as Standard Client users in Spotfire. In addition to role security, the 
Infor CRM Web Client allows Secured Actions to be created. These can further restrict the users able to 
access specific dashboards. 

Though ICAA does enforce the data security defined in Infor CRM, if you are using schedule updates 
within Spotfire, additional steps must be taken to verify security is followed. When using scheduled 
updates, Spotfire stores the data recorded at the time of the scheduled update based on the user who 
created the scheduled update, typically an administrator with access to all data. To verify proper data 
security, additional steps need to be taken. 
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Installation summary 
Use the usernames and passwords below to explore other areas of the product.  

Windows 

Username: 
administrator 
Password: password 

This is the user account to sign in to Windows on your training 
workstation. 

SQL Server 

Username: sa 
Password: password 

This is the sa account to sign in to SQL Server on your training 
workstation. 

Infor CRM demo database (owner) 

Host name: SRV10 
Database owner ID: 
sysdba 
Password: Ma$t3rk3y 

This is the owner of the Infor CRM demo database. 

Infor CRM demo database (user) 

Database admin ID: 
sa 
Password: password 

This is the user account to connect to the saleslogix_eval database. 

Infor CRM admin user 

Username: admin 
Password: password 

This is the user account to sign in to Infor as an administrator.  

Spotfire Professional Client 

Username: admin 
Password: password 

This is the user account to sign in to TIBCO Spotfire Professional Client. 

Infor CRM SSAAService User 

Username: 
SSAAservice 
Password: password 

This is the Infor CRM user used by Spotfire integration components for 
single sign-on and scheduled updates. 
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Lesson 2: Preparing the Infor CRM 
environment 
Estimated time 
3 hours 

Learning objectives 
In this lesson, you will prepare the Infor CRM environment for the TIBCO Spotfire installation. 

Complete the following steps prior to installing Advanced Analytics: 

• Unpack the InforCRM_Advanced_Analytics_v3_0.zip file to a location accessed by both your 
Infor CRM server and the server hosting Spotfire components.  

• Install the license enabling SSAA Service User to connect to Infor CRM data.  
• Copy Sage.Saleslogix.Client.GroupBuilder.dll. 
• Install Saleslogix Legacy and Web Bundles. 
• Build and deploy the Saleslogix Web Portal changes. 
• Create the SSAAService user. 
• Add the SSAAService and the Advanced Analytics role to users. 

After completing this lesson, you will determine if an Infor CRM installation is ready for Infor CRM 
Advanced Analytics. 

Topics 
• Unpack the ICAA zip file 
• Install the add-on license 
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Unpack the ICAA zip file 
The ICAA zip file has been saved for you within the C:\Classfiles\AA Training\ICAA folder on your 
training workstation.  

Use an extraction program to unpack the InforCRM_Advanced_Analytics_v3_0.zip file to a location 
accessed by both your Infor CRM server and the server hosting the Spotfire components. Note: Refer to 
this folder as the Install Folder for this course. 
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Install the add-on license 
Create additional Advanced Analytics user’s using an Add-on User license. Note: Install the license prior 
to use. 

 

 Because you’re using an evaluation copy of the Infor CRM product in this training 
workstation, you’ll use a network user in the exercises to follow. 

 

 

The following steps show how to install an Add-on User license. If an additional user is 
required, these steps should only be performed in a production environment and should 
not be performed on your training workstation. 

 

1. Open the license file and copy the license number. Note: A license is provided by an Infor 
business partner or Infor.  

2. Open Infor CRM Administrator. 

3. Type admin in the Username field. No password is required. 

4. Click Sign In. 

5. Click the Systems Nav Bar. 

6. Click the Licenses tab. 

7. Right-click the screen and then click Add License. The License Wizard window opens. 

8. Click Paste. 

9. Click Next. 

10. Click Finish.  

 

Exercise 2.1: Copy the Sage Saleslogix Client GroupBuilder.dll file 
In this exercise, you will copy the DLL file.  

The Export to Group feature utilizes the Sage.Saleslogix.Client.GroupBuilder.dll file in certain 
business rules. Note: The DLL is in both the SlxClient and SData Bin folders, but it doesn’t 
copy automatically to the Reference Assemblies directory. 

The Sage.Saleslogix.Client.GroupBuilder.dll file is required to support the Spotfire Export to 
Group.zip file. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 
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Verify the GroupBuilder.dll files are available in the Reference Assemblies directory if you 
receive an error message such as the following or similar to: 

• The namespace “Client” does not exist in “Sage.Saleslogix”. 

• Unable to locate assembly reference Sage.Saleslogix.Client.GroupBuilder.dll in 
assemblies or C:\Program Files (x86)\Saleslogix\. 

Exercise steps 

 
Verify you are logged in to the Training Desktop. If not, log in following instructions provided 
by your course instructor.  

Note: If you are taking this course as self-directed learning, follow the instructions on the 
course Lab On Demand screen. 

1. Browse to C:\inetpub\wwwroot\SlxClient\Bin on the Infor CRM Server which is the machine 
hosting the Web Client and SData portals. 

2. Copy Sage.Saleslogix.Client.GroupBuilder.dll and paste it to C:\Program Files 
(x86)\Saleslogix\ReferenceAssemblies. 

 

Exercise 2.2: Install the Advanced Analytics legacy (sxb) and Advanced 
Analytics web (zip) bundles 
In this exercise, you will install the Advanced Analytics legacy and web bundles. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

Exercise steps 

Part 1: Install Advanced Analytics legacy 

1. Open Infor CRM Administrator. 

2. Type admin in the Username field. No password is required. 

3. Click Sign In. 

4. Click the Bundles Nav Bar.  

5. Click Install. 

6. Browse to the C:\Classfiles\AA Training\ICAA install folder. 

7. Open the Bundles folder. 

8. Double-click the Analytics Support.sxb bundle. The Choose Actions to Install dialog box 
opens after the bundle loads. 

9. Click OK. 
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10. Click OK again to close the window. 

11. Select Everyone from the Choose Teams dialog box. 

12. Click OK.  

13. Repeat steps 5 through 12 to install Spotfire Export to Group.sxb. 

Tip: For more information on installing bundles, see the Installing a Bundle topic in the Help file. 

Part 2: Install the Advanced Analytics web (zip) bundles 

Verify you have Write permissions to the bundle installation folder by checking the security permissions in 
the Security tab on the folder properties. 

1. Open Infor CRM Administrator. 

2. Type admin in the Username field. No password is required. 

3. Click Sign In. 

4. Select View > Bundle Manager. 

5. Click Install. 

6. Click the ellipsis next to the Filename field and browse to C:\ClassFiles\AA 
Training\ICAA\Bundles. 

7. Select Web Analytics Support.zip and click Open. The Select Bundle window opens.  

Note: Click Yes if the Confirm Upgrade dialog box opens. 

8. Click Next. The Select Items window opens. 

9. Verify the Portals check box is selected. 

10. Click Next. 

11. Click Finish. 

12. Repeat steps 5 through 11 to install Spotfire Export to Group.zip. 

 

Exercise 2.3: Building and deploying web changes 
In this exercise, you will build and deploy the web portals in the Web Client. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

Exercise steps 
1. Select Build > Build Web Platform.  

Note: All assembly files are compiled for the current project. The build’s status displays in the 
Output window at the bottom of your screen. 

2. Select View > Deployment Explorer once the build completes. 
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3. Expand Deployments. 

4. Right-click Core Portals and then click Deploy.  

Note: This deploys the Process Host, SData, and SlxClient portals. 

5. Close Application Architect. 

6. Reset IIS. 

 

Exercise 2.4: Create the SSAAService user and add the SSAAService to 
the Advanced Analytics role 
In this exercise, you will create the SSAAService user and add the SSAAService to the 
Advanced Analytics role. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Because you’re using an evaluation copy of Infor CRM in this training workstation, you’ll 
create the SSAAService user as a network user. In a production environment, you’ll use the 
add-on license installed earlier. 

Exercise steps 

Part 1: Create the SSAAService user 

1. Open Infor CRM Administrator. 

2. Type admin in the Username field. No password is required. 

3. Click Sign In. 

4. Select the Administrator Nav Bar > Users. 

5. Click Add. The Add window opens. 

6. Select Network User. 

7. Select 1 in the Quantity field. 

8. Click OK. 

9. Click the General tab to create the SSAA Service user in the User Profile pane. 

10. Type Network User in the Type field. 

11. Type SSAAService in the Username field. 

12. Type SSAAService in the Name field. 

13. Type SSAA Service Account in the Title field. 

14. Type SSAA Service – do not modify or delete in the Notes field. 
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15. Click Change Password. 

16. Type password in the Password field. 

17. Click the Teams tab. 

18. Click Manage. 

19. Select each team and verify a check box is selected for each team. 

20. Click OK twice. 

21. Close Infor CRM Administrator. 

Tip: For more information on creating users, see the Adding a User topic in the Help file. 

Part 2: Add the SSAAService to the Advanced Analytics role 

1. Open the Infor CRM Web Client. 

2. Type admin in the Username field.  

3. Type password in the Password field. 

4. Expand the Administration Nav Bar. 

5. Click Analytics System Info. 

6. Click Initialize Defaults.  

Note: This initializes and creates roles, role actions, and dashboard paths if they don’t already 
exist. 

7. Click Roles from the Administration Nav Bar. The Roles List View opens.  

8. Click Advanced Analytics. 

9. Click the Users tab and Add Users. 

10. Select the SSAAService user. Note: Use multi-select to add users to the Advanced Analytics 
role as needed. 

11. Click Add Selected. 

12. Click Close. 

13. Click Save. 

14. Close the Web Client. 
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Lesson 3: TIBCO Spotfire installation 
Estimated time 
3 hours 

Learning objectives 
In this lesson, you will: 

• Install TIBCO Spotfire  
• Configure Infor CRM’s Advanced Analytics components. 
• Assess which Spotfire licenses are required for which groups and users. 

Topics 
• Install TIBCO Spotfire 
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Install TIBCO Spotfire 
 

Exercise 3.1: Install the TIBCO Spotfire Configuration Console and 
TIBCO Spotfire Server 
In this exercise, you will install the TIBCO Spotfire Configuration Console and Spotfire Server 
to configure the database connection, authentication, and deployment files. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

Exercise steps 

Part 1: Run the Advanced Analytics setup 

1. Browse to the C:\Classfiles\AA Training\ICAA install folder. 

2. Right-click SLX Advanced Analytics Setup.exe. 

3. Select Run as Administrator. The setup process starts by opening the Step 1: Create Spotfire 
Database & Server window. 

Part 2: Create the Spotfire Database and Server. Use the following data for connection information 
and to determine where Spotfire Server Install files are located.  
 

Connection 
Information 

Definition 

DB Server DB Server is the name of the database server where the Spotfire 
database is installed. 

Instance (opt.) Instance is the name of the SQL Server instance. If the SQL Server has 
no instance name then leave this area blank. 

Port Number TCP/IP port number for the database server. 

Admin Name Admin Name is the system administrator or user name for the database 
server. This user must have access to create databases and other users.  

Admin 
Password 

Admin Password is the password for the user specified in Admin Name.  

  Click here to view a demo and/or practice this task 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/RunningAdvancedAnalyticsSetup.mp4
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DB Name DB Name is the name used when creating the Spotfire database. The 
default name of “spotfire_server650” used the “650” suffix to show the 
version as 6.5.0.  

User Name User Name is the primary user for the Spotfire database. This user is 
created by the database setup scripts. Note: If you choose an existing 
username, the scripts may generate an error. However, proceed with the 
setup.  

User Password User Password is set when the user’s user name is created. 

Config Pwd A configuration password is set to use for Spotfire configuration. 

Install Spotfire 
Demo 
Database 

The Install Spotfire Demo Database is a check box. If this check box is 
selected then the database set scripts also create the Spotfire Demo 
Database. 

 

1. Select Microsoft SQL Server in the Select Database Server Type pane. 

2. Type SRV10 in the DB Server field. 

3. Keep the Instance (opt.) field blank. 

4. Type 1433 in the Port Number field. 

5. Type sa in the Admin Name field. 

6. Type password in the Admin Password field. 

7. Type spotfire_server650 in the DB Name field. 

8. Type spotfireuser in the User Name field. 

9. Type spotfireuser in the User Password field. 

10. Type spotfireconfig in the Config Pwd field. 

11. Verify the Install Spotfire Demo Database check box is cleared. 

12. Unzip the Spotfire Server Install Files if not already unzipped and select a folder location or 
accept the default location.  

Note: If you select another folder location, the setup program detects whether the folder contains 
the server install. If the folder contains the server install, then the following occurs: 

• The message over the folder path changes 
• Unzip Server Install is disabled 
• Create Database is enabled 

13. Click Unzip Server Install. 
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14. Click Create Database once the unzip completes. 

15. Click Install Spotfire Server once the creation completes. 

16. Click Next. The Step 2: Configure Server window opens. Note: Next is enabled once the install 
completes.  

Part 3: Begin Step 2 which configures the server for Advanced Analytics and requires information 
about the following: 

• Your Infor CRM database 
• Ports 
• User names 

 

 

When you move from Step 1 to Step 2 you may see files unzipping in preparation for the 
configuration. These steps are noted in the Step 2 dialog of the Steps pane.  

 

Use the following information to complete Step 2: 

 

Infor CRM Sign In 
Information 

Definition 

DB Server This is the name of the database server and instance if applicable 
where the Infor CRM database is located. 
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Infor CRM Sign In 
Information 

Definition 

Server Port This is the port number of your Infor CRM database. This field 
defaults to the Port Number used in Step 1. 

DB Name This is the name of your Infor CRM database. 

DB User Name This is the owner of your Infor CRM database.  

DB Password This is the password for the database owner.  

SLX User Name This is the Spotfire Administrator Sign In to Infor CRM.  

SLX Password This is the required password for the Spotfire Administrator.  

SLX Server This is the server name providing the Infor CRM connection. 

SLX Connection This is the name of the connection provided by the Infor CRM 
server. 

SSAAService Password This is the password of the created SSAAService user. 
 

1. Type 1433 in the Server Port field. 

2. Type saleslogix_eval in the DB Name field. 

3. Type sysdba in the DB User Name field. 

4. Type Ma$t3rk3y in the DB Password field. 

5. Type admin in the SLX User Name field. 

6. Type password in the SLX Password field. 

7. Type SRV10 in the SLX Server field. 

8. Type SRV10 in the SLX Connection field. 

9. Type password in the SSAAService Password field. 
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10. Click Modify & Execute Scripts.  

Note: Command windows open and close as scripts execute and deployment files are added. 
Updates are shown in the Step 2 dialog of the Steps pane. 

11. Click Next when enabled. The Step 3: Install Additional Components window opens.  

Step 3 allows you to install the Spotfire Client and Spotfire Web Player.  

 

It’s recommended that your company installs both the Client and Web Player, 
however, each can be installed manually later. 

12. Select the Install Spotfire Client check box. 

13. Select the Install Web Player check box. 

14. Type http://SRV10:3333/sdata in the SData URL field. 

http://srv10:3333/sdata
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15. Click Finish. The TIBCO Spotfire 6.5.0 – InstallShield Wizard dialog box opens. Note: If you 

selected to install additional components, a TIBCO installer runs. 

The setup program installs the additional components selected. The Server Address provided is a 
reference needed for each install and should be saved for future reference. For your training, the 
address has been copied to your clipboard by the setup program. During this time you may see 
file extractions on your machine prior to the installer starting. 

16. Click Next. 

17. Accept the License Agreement and click Next. 

18. Type http://SRV10:8081/spotfire in the Server URL field and click Next. The Ready to Install the 
Program dialog box opens.  

Note: The URL is in your clipboard if you are installing from the Advanced Analytics setup. 

19. Click Install. 

20. Click Finish when available. The TIBCO Spotfire Web Player 6.5.0 – InstallShield Wizard 
welcome window opens.  

Note: If the Spotfire Client Sign In window opens, leave it open in the background to return to 
later. 

21. Click Next. 

22. Accept the License Agreement and click Next. 

23. Verify the installation folder and click Next. The default folder is c:/Program 
Files\TIBCO\Spotfire Web Player\6.5.0\. The IIS Web Application Settings screen opens. 

24. Type SpotfireWeb in the Application Name field. 

25. Type 8080 in the Web Site Port field.  

Note: Always use this port number for the Spotfire Web Player and not another port number for 
another application. 

http://srv10:8081/spotfire
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26. Click Next. The TIBCO Spotfire Server screen opens. 

27. Type http://SRV10:8081/spotfire in the TIBCO Spotfire Server URL field. 

28. Click Next. The Spotfire Administrator Email screen opens. 

29. Enter the Spotfire Administrator Email and click Next. 

30. Click Install. The installation programs should close automatically but if not, click Finish. The 
Tibco Spotfire login screen appears.  

Note: If the Spotfire.Dxp.Web.UpgradeTool.exe security warning opens click Install. 

 

Exercise 3.2: Configure the TIBCO Spotfire Console 
In this exercise, you will import the Infor CRM Data Source, connect the Data Source to the 
database, update and install the Infor CRM information model, add groups and licensing, 
enable Web Client Support dashboard to link to tickets, configure Analytics System 
information, and schedule updates. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Import the Infor CRM Data Source 

1. Open the TIBCO Spotfire shortcut on your desktop if one was created. If not, select Start > All 
Programs > TIBCO > TIBCO Spotfire. 

2. Click Manage Server. 

3. Click Add. The Add Server dialog box opens.  

Note: If the server has already been added, click Cancel and proceed to Step 7. 

4. Type http://srv10:8081/ in the TIBCO Spotfire Server Address. 

5. Click OK twice. 

6. Type admin in the Username field. 

7. Type password in the Password field. 

8. Type http://SRV10:8081/spotfire in the Server field. 

9. Click Login. If you are prompted to choose Upgrade or Work Offline, select Upgrade.  

You are prompted to login again once the upgrade completes. 

10. Select Tools > Library Administration. The Library Administration window opens. 

http://srv10:8081/spotfire
https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/ConfigureTheTIBCOSpotfireConsole.mp4
http://srv10:8081/spotfire
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11. Click Import. The Import dialog box opens. 

12. Click Browse. 

13. Select Saleslogix Data Source.part0.zip. 

14. Click OK. 

15. Clear the Include permissions check box. 

16. Select Replace existing item from the list of If an imported item has the same name or GUID 
as an existing item options.  

17. Click OK. The Select Destination Folder dialog box opens. 

18. Select Library. 

19. Click OK. 

20. Click Close when the import completes. 

21. Close the Library Import window. 

22. Close the Library Administration window. 

Part 2: Connect the Data Source to the database 

1. Select Tools > Information Designer. 

2. Expand Saleslogix Data Source. 

3. Right-click Saleslogix and select Edit. 

4. Select SQL Server (DataDirect) from the Type drop-down list. 

5. Replace <host> with srv10 in the Connection URL field. 

6. Replace <port> with 1433 in the Connection URL field. 

7. Replace <database> with saleslogix_eval in the Connection URL field.  

Note: The database name for SQL Server is case-sensitive.  

8. Verify the Connection URL is set to 
jdbc:tibcosoftwareinc:sqlserver://srv10:1433;databaseName=saleslogix_eval. 

9. Type sysdba in the User Name field. 

10. Type Ma$t3rk3y in the Password field. 

11. Click Save. The password field updates and shows as blank. 

12. Click Close. 

Part 3: Update the Infor CRM information model  

The information model is used to map data from data sources to Advanced Analytics. It’s also used to 
create fields, transform data, and perform other advanced tasks. Information links within the information 
model are used to create dashboards and other analysis. 

The information model is set to use the Saleslogix database by default. If you are using another 
database, follow the steps below to update the information model: 

Note: This process takes a few minutes to run. If you prefer to skip this step during the course, copy the 
following file   
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C:\ClassFiles\AA Training\Saleslogix.Mode.Part0.ICAA_Class.zip  and move it to 
C:\tibco\tss\6.5.0\tomcat\application-data\library. Rename the file to SaleslogixModel.part0.zip. 

1. Browse to C:\Classfiles\AA Training\ICAA\SSAA\SpotfireServer\LibraryDBUtility. 

2. Open LibraryDBChangeUtility.exe. 

3. Verify C:\tibco\tss\6.5.0\jdk\jre\bin is selected in the Java Directory field. 

4. Verify C:\Classfiles\AA 
Training\ICAA\SSAA\SpotfireServer\Library\SaleslogixModel.part0.zip is selected in the File 
to update field.  

5. Verify C:\tibco\tss\6.5.0\tomcat\application-data\library is selected in the Output Directory 
field. 

6. Verify MSSQL is selected in the Database Type field. 

7. Verify saleslogix_eval is selected in the Database Name field. 

8. Verify sysdba is selected in the Database Schema field. 

9. Click Run.  

A message opens stating, “There were errors converting some files, but others have been 
created successfully. Please review the log file.” This is a known issue and can be disregarded. 

10. Click Close to close the Utility tool window. 

Part 4: Install the Infor CRM Installation model to your TIBCO Spotfire server 

1. Select Tools > Library Administration. The Library Administration window opens. 

2. Click Import. 

3. Click Browse and then select Saleslogix Model.part0.zip. 

4. Click OK. The Import dialog box opens. 

5. Clear the Include permissions check box. 

6. Select Replace existing item from the list if an imported item has the same name or GUID as 
an existing item. 

7. Click OK. The Select Destination Folder window opens. 

8. Select Library. 

9. Click OK. 

10. Click Close when the import completes. 

11. Close the Library Administration window. 

Part 5: Add groups and licensing 

Spotfire controls which software features are available to different users by assigning licenses to groups. 
Assign your SSAAService user to Spotfire groups. Users and groups are created, deleted, and managed 
in the Spotfire Client Administration Manager.  

1. Select Tools > Administration Manager. 

2. Click the Groups and Licenses tab. 

3. Click New Group. The New Group dialog box opens. 
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4. Type Standard in the Group Name field. 

5. Select Create group at top level. 

6. Click OK. 

7. Repeat steps 3 through 6 to create the Power group. 

8. Repeat steps 3 through 6 to create the Designer group. 

9. Select Impersonator in the Available groups area.   

10. Click the Properties tab. 

11. Click Edit Members. 

12. Replace a* with SSAA*. 

13. Click Search. 

14. Select the SSAAService group and click Add. 

15. Click OK. 

16. Select Standard in the Available groups area. 

17. Click the Properties tab. 

18. Click Edit Members. 

19. Replace a* with Every*. 

20. Click Search. 

21. Select the Everyone group and click Add. 

22. Click the Licenses tab and then click Edit. 

23. Enable the following: 

• TIBCO Spotfire Web Player 
• TIBCO Spotfire Enterprise Player. 
• TIBCO Spotfire Extensions. 

24. Click OK. 

25. Select Power from the Available groups area. 

26. Click the Licenses tab and then click Edit. The Licenses for ‘Power’ dialog box opens. 

27. Select the TIBCO Spotfire Professional check box. 

28. Click OK. The following licenses are also enabled form the Standard group: 

• TIBCO Spotfire Web Player 
• TIBCO Spotfire Enterprise Player 
• TIBCO Spotfire Extensions 

29. Select Designer from the Available groups area. 

30. Click the Licenses tab and then click Edit. The Licenses for ‘Designer’ dialog box opens. 

31. Select the TIBCO Spotfire Professional check box. 

32. Select the TIBCO Spotfire Advanced Analytics check box. 

33. Select the TIBCO Spotfire Information Modeler check box. 
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34. Click OK. The following licenses are also enabled from the Standard group: 

• TIBCO Spotfire Web Player 
• TIBCO Spotfire Enterprise Player 
• TIBCO Spotfire Extensions 

35. Click Close. 

 

When enabling licenses, you may see a green or red check mark in the enabled 
columns. These marks indicate the licenses the group has enabled. 

Part 6: Enable the Web Client Support dashboard which contains URL links to tickets 

The default URL used should be updated; enabling these links to open the ticket correctly. Use the 
following steps to update the URL: 

1. Select File > Open From > Library. 

2. Double-click Saleslogix. 

3. Double-click Analysis. 

4. Click Support. 

5. Click Open. 

6. Select Edit > Document Properties. 

7. Click the Properties tab. 

8. Select SLXURL from the list of Available properties. 

9. Click Edit. 

10. Type http://srv10:3333/SlxClient/ in the Value field. 

11. Click OK twice. 

12. Select File > Save.  

A message opens stating, “This will update the analysis in the library. Would you like to 
continue?” 

13. Click Yes. 

14. Close the TIBCO Spotfire Client. 

Part 7: Configure the Analytics System information by logging into the Infor CRM Web Client as an 
administrator 

1. Open the Infor CRM Web Client. 

2. Type admin in the Username field.  

3. Type password in the Password field. 

4. Select the Administration Nav Bar > Analytics System Info. 

5. Type http://srv10:8081/spotfire in the Analytics Server URL field. 

6. Type http://srv10:8080/spotfireweb in the Web Player URL field. 

http://srv10:8081/spotfire
http://srv10:8080/spotfireweb
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7. Click Save. 

8. Click Open near the Analytics Server URL to verify the Analytics Server window opens. 

9. Click Open near the Web Player URL to verify the Web Player window opens. Keep this window 
open for the next exercise. 

 

It’s important to save prior to testing each URL as each URL is replaced with a blank 
value if you test prior to saving. 

Part 8: Schedule regular updates to keep KPI data current. Updates are configured in the 
Administration area of the Infor CRM Web Client 

1. Select Tools > Scheduled updates from the Spotfire Web Player window.  

2. Click Add analysis file. The Select Schedule File window opens. 

3. Select Add analysis file > Saleslogix > Analysis. 

4. Select Marketing. The Configuration Update Schedule window opens. 

5. Select Automatic within the Update Method area. 

6. Select the times when users will be accessing data in the Keep analysis pre-loaded to assure 
fast access between area. 

7. Select Reload and trigger update (within the specified time frame) every and enter a time in 
minutes of how often data is to be refreshed. 

8. Click Save. 

9. Repeat steps 2 through 8 for the Support and Sales analysis. 

10. Close the Schedule Updates and Web Player windows.  

11. Click Sign off to close the Infor CRM Web Client. 
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Lesson 4: Infor CRM Advanced 
Analytics customizations 
Estimated time 
8 hours 

Learning objectives 
In this lesson, you will: 

• Demonstrate adding a custom Infor CRM table to Spotfire. 
• Demonstrate adding third-party data to Spotfire. 
• Design visualizations that limit data based on other visualizations. 
• Design visualizations that use custom expressions and bookmarks. 
• Apply Infor CRM security to a custom table and dashboard. 
• Launch a dashboard in Infor CRM Windows and Web. 

Topics 
• Customizing ICAA 
• Customization best practices 
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Customizing ICAA 
 

Exercise 4.1: Create a custom Infor CRM table 
In this exercise, you will create a custom Infor CRM table. It’s recommended for the company 
to install the add-on user license provided with ICAA so an existing named user license is not 
consumed in the production environment. However, several named user licenses are 
available for use in your training workstation. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Create a custom Infor CRM table 

1. Select Start > All Programs > Infor CRM > Administrator. 

2. Type admin in the User ID field.  

3. Type password in the Password field. 

4. Click Sign In. 

5. Select Manage > Database. The Database Manager screen opens. 

6. Click Create New Table. The Table Properties dialog box opens. 

7. Type ClientProject in the Table Name field and then press tab to exit out of the field.  

Notice the text defaults to CAPS. 

8. Type ClientProject in the Display Name field. 

9. Verify (None) is selected in the Association field. 

10. Type contains project management details in the Description field. 

11. Click OK. 

 

The ClientProject table may have relationships (such as Account, Contact, Ticket, or 
User) with several other tables. If you associate another table using the 
Association drop-down list, your current table appears below the table with which 
you associated. This is done so we can create the relationships in Infor CRM later. 
However, you’ll need to recreate the relationships when the data model is imported 
into ICAA. We do not touch on this training in the training workstation. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/CreateACustomInforCRMTable.mp4
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The table is added to the bottom of the Tables tree view. Review fields created automatically: 

 
The table isn’t committed to the database yet so let’s create additional fields we want the 
ClientProject table to have, such as project title, start date, and end date. 

12. Right-click in the white space and select Create New Field. Verify the Table Name field reads 
CLIENTPROJECT. 

13. Add the following properties: 
 

Field Name Display Name Data Type Length 

TITLE Title String 32 

DESCRIPTION Description Stringds 255 

PROJECTTYPE ProjectType String 64 

STARTDATE StartDate Date/Time  
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Field Name Display Name Data Type Length 

ENDDATE EndDate Date/Time  

ESTIMATEDCOST EstimatedCost Currency  

ACTUALCOST ActualCost Currency  

ACCOUNTID AccountId SLX Standard Id  

MANAGERID ManagerId SLX Standard Id  

 

14. Click OK and repeat the process for any fields you need to create.  

15. Wait for the Database Manager to reload. 

16. Click Apply Changes. 

17. Close Administrator. 

 

In the above exercise, you created an entity with different data types to explore 
advanced aggregation when building visualizations. For example, you can use 
DateDiff to calculate the number of days between the StartDate and EndDate for a 
project. 

Typically, when creating a new custom entity in Infor CRM you may choose to 
include the SECCODEID for security purposes, i.e. users can only see data in which 
they can access. You can use this property through the Account join which you’ll set 
up inside Spotfire later. 

Part 2: Insert sample data 

1. Select Start > SQL Server Management Studio. 

2. Verify the Server name is set to SRV10 and click Connect to use Windows Authentication. 

3. Select File > Open > File. 

4. Browse to C:\Classfiles\AA Training\ and open the InsertIntoClientProject.sql file. 

5. Click Open. 

6. Click Execute once the file opens.  

 
7. Expand SRV10 > Databases within the Object Explorer pane. 
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8. Expand saleslogix_eval > Tables. 

9. Right-click the sysdba.CLIENTPROJECT table and then click Select Top 1000 Rows.  

Notice there are 25 rows of data. You can manually add rows too. 

10. Close SQL Server Manager Studio. 

 

 
What can be analyzed from the data? 

 

You can analyze items, such as: 

• Projects that charge the highest actual costs and for which accounts. 

• Project managers who spend the most time on their projects. 

• Project managers who have the most projects. 

 

You have enough data in this example to justify a separate Project Management dashboard document 
and two dashboard pages at a minimum, i.e. Project Cost and Project Time. 

Before you can design a dashboard using the above date, you need to import the dashboard into the 
information model within Spotfire. Within the information model you’ll set up joins, column elements, and 
any additional information you want to use within an information link. This is how you know what data to 
include in an analysis (dashboard). 

 

Exercise 4.2: Create a parallel model for customization 
In this exercise, you will back up the main data model and create a folder structure for 
“Training.” 

Prior to making any customizations, export the main data model folder. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Backup the main data model 

1. Open TIBCO Spotfire Professional Client. 

2. Type admin in the User ID field if prompted.  

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/CreatingParallelModelCustomizations.mp4
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3. Type password in the Password field if prompted.  

4. Click Sign In. 

5. Select Tools > Library Administration. The Library Administration window opens.  

The library contains all your analyses, color palettes, information links, data sources, and data 
models.  

6. Double-click the Saleslogix folder. 

7. Click the Model folder and then click Export. The Export dialog box opens. 

 
8. Type InforCRM_Model in the File name field. 

9. Verify All Items is selected in the Export items of type field.  

 
10. Click OK. The Library Export dialog box opens. 

11. Click Close once the export finishes. 

12. Close the Library Administration window.  

The backup just created is in C:\tibco\tss\6.5.0\tomcat\application-data\library. 

Part 2: Create a folder structure for “Training” 

1. Select Tools > Information Designer. 

2. Click the Elements tab and then right-click in the white space.  

3. Click New Folder. The New Folder dialog box opens. 

4. Type Training in the Name field. 

5. Click OK. 
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6. Create the following sub folder structure for: 

• Analysis 
• Information Link 

• Client Project Module 
• Marketing Module 
• Sales Module 
• Support Files 

• Model 
• Data Tables 
• Filters 
• Joins 
• Security Model 

 

Whenever a new column, join, or information link is created, they should be saved in the 
appropriate Training sub folder. 
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Exercise 4.3: Importing a custom table into Spotfire 
In this exercise, you will connect to a data source, customize the Infor CRM data model 
within Spotfire, and create the CLIENTPROJECT – ACCOUNT join, CLIENTPROJECT – 
USERINFO join, and information link. 

Whether you plan to use custom data from a third-party source or from the Infor CRM 
database, you need to be able to connect to the data source from within Spotfire. You can 
connect to almost any provider if you enable that provider when ICAA is installed.  

Because you’re using a custom table inside Infor CRM, you’re already connected to a data 
source which was configured during installation. However, if you use a third-party data 
source from a different database server other than the Infor CRM database, you can create a 
new connection. 

The steps below are for reference only. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Connect to a data source 

On the training machines, the following steps have already been completed. However, if a Data Source 
was not previously created or you need to create another Data Source, these would be the steps to 
follow. 

1. Open TIBCO Spotfire Professional Client.  

2. Select Tools > Information Designer. 

3. Click the Elements tab. 

4. Select New > Data Source. The Data Source screen opens.  

This screen allows you to choose the type of Data Source and enter the Connection URL. 

5. Update the Connection URL with the appropriate <host>, <port>, and <database name> (i.e. 
jdbc:tibcosoftwareinc:sqlserver://srv10:1433;databaseName=saleslogix_eval). 

6. Click Close but leave the Information Designer window open. 

Part 2: Customize the Infor CRM model within Spotfire by creating new elements, joins, and 
information links in your model 

Whether using a custom Infor CRM table or a table from an external data source, the process is identical. 

1. Click the Elements tab. 

2. Expand Training > Model > Data Tables. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/ImportingACustomTableIntoSpotfire.mp4
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3. Right-click Data Tables and select New. 

4. Click Folder. The New Folder dialog box opens.  

5. Type ClientProjects in the Name field. 

6. Click OK. The New ClientProjects folder opens and is empty.  

Tip: You can right-click the folder to add columns individually, however, an easier method is to 
create multiple element columns at once through the Data Source. 

7. Click the Data Sources tab within the Information Designer window. 

8. Expand Saleslogix > saleslogix_eval > sysdba. 

9. Right-click the CLIENTPROJECT node and select Create Column Elements.  

10. Click Create Columns. The Create Multiple Columns dialog box opens.  

11. Expand Library > Training > Model > Data Tables. 

12. Click the ClientProject folder and then click Create Columns. 

 
13. Return to the Elements tab when the import finishes. 

14. Expand the ClientProject folder in the Training node to view the element columns.  
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To alias any of the elements in your custom data tables folder or the out-of-the-box 
Infor CRM folder, e.g. COMPANY instead of ACCOUNT, right-click an element and 
click Edit Properties. The value you choose for the Name will appear within the 
Information Designer and any visualization properties as you or other Spotfire 
Profession client users develop. 

If you do not alias column elements within the Information Designer, you can alias 
individual column names to change the display text for the user. 

Part 3: Create the CLIENT PROJECT – ACCOUNT join 

1. Click Create Join within the Information Designer window. The Join Element screen opens. 

2. Click the Data Sources tab. 

3. Expand Saleslogix > saleslogix_eval > sysdba > ClientProject. 

4. Select the ACCOUNTID element column. 

5. Click Add to include it in the Join columns pane.  

6. Expand Saleslogix > saleslogix_eval > sysdba > Account. 

7. Select the ACCOUNTID element column. 

8. Click Add to include it in the Join columns pane.  

9. Verify the Condition is set to Inner Join. 

10. Click Save. 
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11. Expand Library > Training > Model. 

12. Select Joins. 

13. Leave the default name chosen. 

14. Click OK. 

15. Click Save. 

Part 4: Create the CLIENTPROJECT – USERINFO join 

1. Click Create Join within the Information Designer window’s Start tab. The Join Element 
screen opens. 

2. Expand Saleslogix > saleslogix_eval > sysdba > ClientProject. 

3. Select the MANAGERID element column. 

4. Click Add to include it in the Join columns pane. 

5. Expand Saleslogix > saleslogix_eval > sysdba > USERINFO Data Source. 

6. Select the USERID element column. 

7. Click Add to include it in the Join columns pane.  
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8. Verify the Condition is set to Inner Join. 

9. Click Save. 

 
10. Expand Library > Training > Model. 

11. Select Joins. 

12. Leave the default name chosen. 

13. Click OK. 

14. Click Save. 

Part 5: Create the information link 

The information link is a container for columns, filters, joins, or procedures to use on a dashboard. 

1. Click the Elements tab within the Information Designer window. 

2. Expand Training > Information Link. 

3. Right-click the Sales Module folder and select New > Information Link. The Information link 
screen opens.  

4. Select Training > Model > Data Tables > ClientProject.  



 

Infor CRM: Advanced Analytics v3.0 Training Workbook 49 
   

  © 2018 Infor Education. All rights reserved. No part of this Training Workbook may be reproduced or transmitted in any form, without written permission. 

5. Select the following columns and then click Add to copy them into the Elements drop-down list: 

• CLIENTPROJECTID 
• ACCOUNTID 
• MANAGERID 
• TITLE 
• DESCRIPTION 
• STARTDATE 
• PROJECTTYPE 
• ENDDATE 
• ESTIMATEDCOST 
• ACTUALCOST 

 
6. Click the Elements tab. 

7. Expand Saleslogix > Model > Data Tables > Account. 

8. Select Account and SECCODEID.  

9. Click Add to add them to the Elements pane. 

10. Click the Elements tab. 

11. Expand Saleslogix > Model > Data Tables > Userinfo. 

12. Select USERNAME. 

13. Click Add. 

14. Expand the Join path. 

15. Click Suggest Joins.  

Note: The related joins (CLIENTPROJECT – USERINFO Inner Join and CLIENTPROJECT – 
ACCOUNT Inner Join) appear in the list. 

16. Click SQL to view the join properties. 

17. Click OK.  
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18. Click Save. 

19. Browse to Library and select Training > Information Link > Sales Module. 

20. Change the name of the information link to Projects. 

21. Click Save. 

22. Click Close to exit the Information Designer. 
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Exercise 4.4: Add a table to a dashboard 
In this exercise, you will add a data table to a dashboard. Adding a data table loads data on 
the dashboard analysis you have open. For example, if you want to add a new Project 
Management dashboard page to the out-of-the-box Sales dashboard (analysis) you need to 
open the Sales analysis. To modify out-of-the-box dashboard documents, click Edit, click 
Document Properties, and set the LoadSecurity property to T. Also, click File, click Save 
As, click Library Item, and save it to your customization folder, i.e. Training. 

However, for this training you are asked to create a new Projects dashboard (analysis) 
separate from the out-of-the-box dashboards. The new dashboard is exclusively used for 
project management-related data. 

In this exercise, you’ll add the data table now so a new dashboard is created automatically. 
You can also create a new dashboard first and add the table data instead. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Open TIBCO Spotfire Professional Client. 

2. Select File > Add Data Tables. The Add Data Table window opens.  

3. Select Add > Information Link. The Select Information Link window opens. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/AddATableToADashboard.mp4
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4. Browse to Library and select Training > Information Link > Sales Module. 

5. Click ClientProjects. 

6. Click OK to return to the Add Data Tables window. 

7. Click OK again. A new dashboard page opens.  

The selected data from the CLIENTPROJECT table appears in a Bar Graph visualization. 

8. Right-click the visualization and select Switch Visualization To > Table.  

You can now see the data from your custom Infor CRM table. 
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9. Select File > Save As > Library Item. The Save As Library Item window opens. 

10. Browse to Library and select Training > Analysis.  

11. Type ClientProject in the Name field. 

12. Click Finish. 

13. Click Close in the Save as Library Item window. 

You can add several dashboard pages to this newly created dashboard as well as redesign it with 
more intuitive visualizations and filters. But first, let’s explore ways to reload data after it is added 
to a dashboard.   

 

Exercise 4.5: Reload data in a dashboard 
In this exercise, you will reload data. If you have data loaded onto a dashboard you can 
make changes to the model later. For example, you can create a new calculated field for 
COSTVARIANCE after the data has already been loaded. To make sure a new column 
element loads properly, let’s use a calculated field as an example. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Select Tools > Information Designer. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/ReloadData.mp4


 

54  Lesson 4: Infor CRM Advanced Analytics customizations 
  

 © 2018 Infor Education. All rights reserved. No part of this Training Workbook may be reproduced or transmitted in any form, without written permission. 

2. Click the Elements tab. 

3. Expand Training > Model > Data Tables. 

4. Right-click ClientProject and select New > Column.  

5. Click the Data Sources tab. 

6. Expand Saleslogix > saleslogix_eval > sysdba > CLIENTPROJECT. 

7. Select ESTIMATEDCOST and ACTUALCOST. 

8. Click Add. 

9. Type %2-%1 in the Expression field.  

The Expression field uses the alias value. The expression you want is ActualCost – Estimated 
Cost so you may need to verify the alias for each.  

Tip: For a list of other allowed functions, search the Help File for Aggregate Functions. 

 
10. Click Save. 

11. Expand Library > Training > Model > Data Tables > ClientProject. 

12. Type COSTVARIANCE in the Name field. 

13. Click Save.  

A new column element for COSTVARIANCE appears under the ClientProject folder within the 
Elements tab. 

14. Click the Elements tab. 

15. Expand ClientProject. 

16. Click the COSTVARIANCE column and then click Add to include it in the Elements pane. 

17. Click Save.  

18. Click Close. 

19. Close the Information Designer.  

20. Select Edit > Data Table Properties in the ClientProject dashboard. 

21. Click Refresh Data and select Without Prompt. The calculated field can now be use inside a 
visualization or as a filter. 

22. Click Settings to verify the new field was added.  

23. Click OK when finished.  

The new column element is listed as an information link parameter. Note that you may need to 
select Data on demand to scroll down and view. If so, select All data at once before clicking 
OK. 
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24. Click OK again to close the Data Table Properties window. 

 

You can also use Reload Data in the toolbar to reload all data tables, however, this 
option can take a while if one or more tables is large. Refresh Data may be 
unavailable for some of your data tables if you added rows, columns, or frozen data 
in an embedded data table. 

 

Exercise 4.6: Load data from an external database 
In this exercise, you will use data from a third-party database in ICAA. One way to use third-
party data is by joining data to an existing Infor CRM table. For this scenario, follow the steps 
in exercise 4.3 to create a connection, column elements, joins, and an information link.  

Infor CRM has added a new ExternalProjects database, however, it’s sitting on the same 
database server as Infor CRM in your training workstation. Rather than duplicate the steps in 
the Information Designer let’s use an easier and alternate method of adding the data directly 
from the external database. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/LoadDataFromAnExternalDatabase.mp4
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Exercise steps 
1. Open TIBCO Spotfire Professional Client. 

2. Select File > Add Data Tables. The Add Data Tables window opens. 

3. Select Add > Database.  

Note: You may need to scroll down to see this option. The Open Database dialog box opens. 

 

In a production environment, Infor CRM recommends that you add a data table from 
an information link to join the data in Infor CRM. 

4. Select SqlClient Data Provider. 

5. Click Configure. 

 
6. Type SRV10 in the SQL server name field. 

7. Select Use Windows Authentication. 

8. Select ExternalProjects under Connect to a Database. 

9. Click OK twice. The Specify Tables and Columns dialog box opens. 

10. Expand dbo > Projects and dbo >Tasks within the Tables, views and columns area. 

11. Select the Projects and Tasks check boxes to select all. 

12. Type ExternalDB in the Data source name field. 

13. Click OK twice. 

A new dashboard page is added with a bar graph showing the data (1 records). By not creating 
the joins first and using an information link the raw data is not very useful. You can use the data 
table drop-down to switch which table is providing the data, ExternalDB or saleslogix_eval. 
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Exercise 4.7: Design a new projects dashboard 
In this exercise, you will add visualization and filters. If the dashboard is not loaded you can 
use the Recent Analyses view on the start page or select File > Open From Library and find 
your dashboard. 

Your results after completing this lesson should look similar to the following image: 

 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Right-click the Page dashboard page and select Rename Page. The Rename Page dialog box 

opens. 

2. Type Project Cost in the Title field. 

3. Click OK. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/AddVisualizationFilters.mp4
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4. Click X to close the projects table visualization.  

Note: The bar with X doesn’t appear until your mouse hovers near the top of the visualization. 

5. Select Insert > New Visualization to add the following visualizations: 

• Bar chart 
• Pie chart 
• Cross table 

6. Select Insert > New Text Area to insert three text areas. Drag the visualizations and text areas 
into the appropriate locations as show below: 

 
7. Right-click anywhere in the Filters pane and select Organize Filters. 

8. Clear the CLIENTPROJECTID, ACCOUNTID, MANAGERID, and DESCRIPTION check boxes in 
the Project Cost – Organize Filters window. 

9. Select ACCOUNT > Move First. 

10. Select USERNAME > Move First. 

11. Click OK.  

12. Right-click the ACCOUNT filter and select Filter Type > List Box Filter. 

13. Right-click the USERNAME filter and select Filter Type > List Box Filter. 

14. Right-click the PROJECTTYPE filter and select Filter Type > List Box Filter. 

The Filters pane should appear similar to the following figure. You can select a filter to see how 
the visualization data changes. 
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The Filters pane is now modified to better match your data types. As a reminder, filters limit data 
on the page for all visualizations whereas markings or filter boxes outside of the Filter pane apply 
to one visualization and not the entire page.  

Understanding markings 

In the next exercise, you’ll create dimension controls using document properties which change your 
visualized data and use markings in multiple visualizations on a page.  

A marking represents a selection which occurs when the user interacts with the visualization. For 
example, when a visualization allows markings a user can either click on a bar in a chart to mark a single 
item or click-and-drag a rectangle around a group of bars in a chart. Marked rows are identified by a 
separate color. 

 

 

Average Cost Variance Bar Graph Markings 
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As a developer, you decide the behavior of the visualization(s) based on each marking instance you 
create. The following six scenarios describe common approaches for configuring markings when you 
have two or more visualizations. 
 

Behavior Description Example 

Use the 
same 
marking, no 
data limiting 

This option uses one marking instance 
for either all visualizations on a page or 
all visualizations in the dashboard, i.e. 
all pages.  
This means if a user makes a selection 
on one chart, all other charts using this 
marking instance automatically use the 
same identifying color to highlight the 
corresponding value. 
In this example, if the user marks a bar 
from the top charge the corresponding 
slice in the pie is automatically marked 
and vice versa. 

 

Use 
separate 
markings, 
no data 
limiting 

This option uses a separate marking 
instance for each chart.  
In this example, a selection in the bar 
chart has no effect on a selection in the 
pie chart and vice versa. Additionally, a 
selection in the pie chart uses a different 
identifying color. Clicking on sector turns 
the marking dark blue on the pie chart 
which is unrelated to the bar chart 
marking. 
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Use no 
markings, 
no data 
limiting 

This option prevents users from making 
markings in one or more of the 
visualizations. 
In this example, only the pie chart is set 
to use no markings. This means the 
user can select anything in the bar 
charge but cannot select anything in the 
pie chart. Clicking on a sector does not 
result in a marking. 

 

Use the 
same 
marking, 
data limiting 

This option is not useful in most 
situations.  
In this example, only the pie chart is set 
to limit data. This means the user’s 
selection in the bar chart makes up 
100% of the pie chart’s total data 
automatically when selected. 
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Use 
separate 
markings, 
data limiting 

This option uses separate marking 
instances for each chart, however, the 
total data set for the pie chart is limited 
by the marking used in the bar chart. 
This means the pie chart won’t be 
visible until a marking is made in the bar 
chart. Once visible, the user can select 
a segment in the pie chart without 
affecting the marking from the bar chart. 
In this example, clicking on a sector 
turns the marking on in the pie chart 
which is unrelated to the bar chart 
marking. 
If you have a third visualization with a 
separate marking you can limit the pie 
chart to use data from both markings in 
which case the total data set would 
reflect the intersection of the markings, 
i.e. only the data common to both 
charts. 

 

Use no 
markings, 
data limiting 

This option is most commonly used.  
In this example, only the pie chart is set 
to use no markings and limit data which 
means the pie chart won’t be visible 
until a marking is made in the bar chart. 
Additionally, the user cannot click to 
select anything in the pie chart. 

 

 
Table 1: Marking Behaviors & Descriptions 

 



 

64  Lesson 4: Infor CRM Advanced Analytics customizations 
  

 © 2018 Infor Education. All rights reserved. No part of this Training Workbook may be reproduced or transmitted in any form, without written permission. 

Exercise 4.8: Create dimension drop-down controls with document 
properties 
In this exercise, you will create dimension drop-down controls with document properties. 
Let’s begin by adding a new document property which you’ll use for on-demand data loading. 
Document properties are variables applicable throughout the document. For example, a 
currency rate used in calculations in different columns. By using a property instead of placing 
the column name directly on the axes you only need to change a single value (the property 
value) to change all axes where property is used.  

In your first dashboard page, you won’t reuse the same document property and instead will 
create a new document property for each visualization on the page. Each of the document 
properties holds one or more column names which allows the user to dynamically choose 
which data to display on each chart. 

 
Drop-down Controls with Properties 

A document property within an expression is denoted as ${MyProperty} and reviewed later. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

Exercise steps 

Part 1: Create dimension drop-down controls with document properties 

1. Right-click in the Text Area pane above the Bar Chart and select Properties. The Text Area 
Properties window opens. 

2. Clear the Show title bar check box and then click Close. 

3. Right-click the Text Area pane again and select Edit Text Area. The text editor’s toolbar 
appears. 

4. Type Summarize By: with a space at the end to create the label for the drop-down list. 

5. Select Insert Property Control > Drop-down list. The Property Control window opens. 
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6. Click New. The New Property dialog box opens. 

7. Type CostVariance in the Property name field. 

8. Click OK. 

You’re creating a new property holding one or more column names. You’ll use this new property 
as the X-Axis so the user can choose what to see at runtime. These properties also determine 
colors or the Y-Axis.  

 
Note how all columns from the CLIENTPROJECT table are automatically included in the drop-
down list in the Settings pane of the Property Control dialog box. 

9. Type PROJECTTYPE or USERNAME or ACCOUNT or ACCOUNTID in the Selectable columns 
(limit through expression) field.  

10. Click OK. 
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11. Right-click the text editor area above the Bar Chart and clear Edit Text Area. 

12. Click the drop-down list to see the properties you chose.  

Note: Nothing happens yet. You’ll need to tie the new CostVariance property to the visualization 
you want changed, i.e. the bar chart. 

 
Prior to modifying the bar chart properties let’s copy and paste the contents of the Text pane to 
the remaining text area and set two more properties for use on the pie chart and cross table 
visualizations.  

13. Right-click the Text Area above the Pie Chart and select Properties. 

14. Clear the Show title bar check box. 
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15. Right-click the Text Area above the Pie Chart again and select Edit Text Area. 

16. Return to the first Text Area, select the contents of the text area in edit mode, and then press 
CTRL+C to copy. 

 
17. Click the Text Area above the Pie Chart and then press CTRL+V to paste the label and drop-

down control. 

18. Right-click the new control and select Edit Control. The Property Control window opens. 

19. Click New. The New Property window opens. 

20. Type ActualCost in the Property name field. 

21. Click OK.  

The same settings apply for selectable columns limited through expression. You’ll use the same 
properties: PROJECTTYPE, USERNAME, and ACCOUNT, however, you do not want 
ACCOUNTID. 

22. Delete or ACCOUNTID. 

23. Click OK. 

24. Right-click in the Text Area above the Pie Chart area and select Properties. 

25. Clear the Show title bar check box and click Close. 

26. Right-click the Text Area above the Pie Chart and clear the Edit Text Area radio button. 

Part 2: Repeat the process for the Text Area above the Cross Table 

1. Right-click in the Text Area above the Cross Table and select Properties. 

2. Clear the Show title bar check box and then click Close. 

3. Right-click the Text Area above the Cross Table again and select Edit Text Area. 

4. Press CTRL+V to past the label and drop-down control. 

5. Right-click the new control and select Edit Control. The Property Control window opens. 

6. Click New. The New Property window opens. 

7. Type AccountCost in the Property name field. 

8. Click OK. 

The same settings apply for selectable columns limited through expression. 

9. Verify PROJECTTYPE or USERNAME is selected in the Selectable columns (limit through 
expression) field but delete or ACCOUNT. 

10. Click OK. 
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Exercise 4.9: Edit bar chart properties 
In this exercise, you will edit a bar chart to use dimension variables. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Edit a bar chart 

1. Right-click the bar chart visualization and select Properties. The Bar Chart Properties window 
opens. 

2. Click the General tab. 

3. Type Average Cost Variance in the Title field. 

4. Click Appearance. 

5. Select the Side-by-side bars and Sort bars by value check boxes. The visualization changes in 
the background as you work. 

 

Part 2: Compare ESTIMATEDCOST with ACTUALCOST by adding two columns for the Y-Axis 

1. Click Value axis in the Bar Chart Properties window.  

This represents the Y-Axis of the bar graph.  

2. Select Multiple scales. 

3. Select ESTIMATEDCOST from the first drop-down list in the Columns pane. The result is 
Sum(ESTIMATEDCOST). This column may have already been added for you. 

4. Replace the Sum aggregation and select Avg (Average). The result is Avg(ESTIMATEDCOST). 

5. Select Avg(ACTUALCOST) from the second drop-down list in the Columns pane. 

Now you have two columns to compare against. The values may appear in red with no data 
showing in the background. This is because when multiple columns are used on the Y-Axis you 
need to use column names on either the X-Axis or the colors. Since you’re using a custom 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/EditABarChart.mp4
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property for the X-Axis in your training workstation this will be fixed once you get to the Colors 
screen. Right-click the Columns pane and click Custom Expression. 

6. Alias the column names by modifying the following Expression field:  

• AVG([ESTIMATEDCOST]) as [ESTIMATED] 
• AVG([ACTUALCOST]) as [ACTUAL] 

7. Click OK. 

8. Click Category Axis. This represents the X-Axis of the bar graph. 

9. Select Show zoom slider. 

10. Right-click ACCOUNTID in the Columns pane and select Set from Property. The Set from 
Property window opens. 

11. Click CostVariance. This was created earlier when the bar chart’s dimension drop-down was 
created. 

12. Click OK. 

 
You’ve connected the bar chart with its drop-down control. The value selected from the drop-
down list in the first Text Area is the X-Axis. 

13. Click Colors within the Bar Chart Properties window. 

14. Click the drop-down list within the Columns pane and select (Column Names) if the column is 
not already listed. 

The chart populates with data in the background. 

15. Click Color Schemes and select Spotfire categorical. The Apply Method dialog box opens. 
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16. Select the Colors matched to values radio button. 

17. Click OK. 

 

Part 3: Save this color scheme to use for all visualizations in this training workstation 

1. Select Color Schemes > Save As > Document Color Scheme. The Save Document Color 
Scheme dialog box opens. 

2. Type Infor CRM in the New color scheme field. 

3. Click OK. 

 
4. Click Legend. 
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5. Clear all check boxes except Marketing and Color by. 

6. Click Close. 

The bar chart should resemble the following figure: 

 
 

Exercise 4.10: Edit a pie chart 
In this exercise, you will edit a pie chart to use dimension variable. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Select two or more columns in the bar chart to verify you can still see the pie chart in the 

background when changes are made to the marking detail settings.  

2. Right-click the pie chart visualization and select Properties. The pie chart Properties window 
opens. 

3. Click the General tab. 

4. Type Total Actual Cost in the Name field. 

5. Click Data. 

6. Select (None) from the Marking drop-down list.  

7. Select the Marking check box.  

These settings determine how the pie chart populates based on a selection in the bar chart. If no 
markings are made the pie chart does not appear. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/EditAPieChart.mp4
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8. Click Appearance. 

9. Select the Sort sectors by size check box. 

10. Click Colors. 

11. Right-click the Columns field and select Set from Property. The Set from Property dialog box 
opens. 

12. Click the ActualCost property. 

13. Click OK.  

This property was created earlier when you created the pie chart’s dimension drop-down. 

You’ve now connected the pie chart with its drop-down control. The value selected from the drop-
down list is the sector of the pie. 

14. Select Color Schemes > Document Color Schemes > Infor CRM. The Apply Method dialog 
box opens. 

15. Click Colors matched to values. 

16. Click OK. 

17. Click Size within the pie chart Properties window. 

18. Select ACTUALCOST from the Sector size by drop-down list.  

The result is Sum(ACTUALCOST). If not, change the Aggregation appropriately. 

19. Right-click the Sector size by field and select Custom Expression. The Custom Expression 
dialog box opens. 

20. Type Total Cost in the Display name field. 

21. Click OK. 

 
22. Click Labels within the pie chart Properties window. 

23. Select the Sector percentage check box. 

24. Change the Sector percentage threshold value to 2. 



 

Infor CRM: Advanced Analytics v3.0 Training Workbook 73 
   

  © 2018 Infor Education. All rights reserved. No part of this Training Workbook may be reproduced or transmitted in any form, without written permission. 

25. Click Legend. 

26. Clear all check boxes except Color by and Sector size by. 

27. Click Close. 

The visualization should look similar to the following figure depending on the columns you 
selected: 

 
 

Exercise 4.11: Edit cross table properties 
In this exercise, you will modify the Project visualization cross table to use my document 
variable. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Right-click the cross-table visualization and select Properties. The Cross-Table Properties 

window opens. 

2. Click the General tab. 

3. Type Total Account Cost in the Name field. 

4. Click Data. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/EditACrossTable.mp4
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5. Verify Marking is selected in the Marking drop-down list.  

This means the bar chart and cross table share the same marking. 

6. Clear the Marking check box.  

This means data in the cross table is not dependent on the selected marking.  

7. Click Appearance. 

8. Select the Grand total for columns check box. 

9. Click Axes. 

10. Right-click the Horizontal drop-down list and select Set from Property. The Set from Property 
window opens. 

11. Click AccountCost and click OK.  

This was created earlier when you created the cross-table’s dimension drop-down list. 

You’ve now connect the cross table with its drop-down control. The value selected from the drop-
down list is the column(s) of the cross table. 

12. Select ACCOUNT from the Vertical drop-down list. 

13. Select Sum(ACTUALCOST) from the Cell values drop-down list.  

14. Right-click anywhere in the Cell values pane and select Custom Expression. 

15. Click OK to return to the Cross-Table Properties window. 

16. Click Formatting. 

17. Select Currency from the Category drop-down list. 

18. Select 2 in the Decimals field. 

19. Select the Use thousands separator check box. 

20. Click Legend. 

21. Clear the Show legend check box. 

22. Click Close. 

23. Click the down arrow on the cross-table visualization title bar and disable Axis Selectors. 

The visualization should look similar to the following figure depending on the columns selected. 
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24. Test the Select dimension drop-down list to see the rows change for each new dimension. 

25. Select File > Save As > Library Item. The Save as Library Item window opens. 

26. Save as Projects and then click Finish. 

27. Click Yes to overwrite Projects.  

28. Click Close in the Save as Library Item window. 
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Exercise 4.12: Create the Project Time dashboard page 
In this exercise, you will create a Project Time dashboard page. Let’s begin by creating a 
new dashboard page by copying and reformatting three visualizations. You’ll create a new 
document property called Duration which two of your visualizations will share. When a user 
picks an item from the drop-down list, both charts update to reflect the selection. 

Next, you’ll modify the properties of each visualization. Before you begin, let’s explore 
custom expressions and aliasing. 

When you set a column name inside a chart’s properties, e.g. Category Axis, Value Axis, 
Color, or Size, you can choose to set from a custom property or from an existing column in 
the model. To apply aggregation to the column the Properties window contains several 
commonly-used functions. 

Using an option from this menu lets you set simple column values quickly. However, you can 
also right-click inside the Columns pane and click Custom Expression to manually write the 
functionality. 

The Custom Expression editor provides more flexibility for designing complex expressions 
using columns or properties. 
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Refer to the TIBCO Spotfire User’s Guide (F1) for more tips on using custom expressions. 
Here are some items to keep in mind: 

• Use the Functions panel to see a list of all functions and examples you can use as 
expressions, i.e. Binning, Conversion, Date and Time, Logical, Math, Operators, OVER, 
Property, Ranking, Spatial, Statistical, and Text. 

• Use the Expression pane to write an expression. Enclose column names or property 
names in brackets. Use parentheses to enclose function content, except for operators. 
For example: Avg(DateDiff([ENDDATE],[STARTDATE])) 

Use the as [ALIAS NAME] format to alias a column or property within the Expression pane. 
For example: Sum([ACTUALCOST]) as [Total Cost]. Alternatively, you could specify the alias 
inside the Display name field at the bottom of the dialog box. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Create the Project Time dashboard 

1. Right-click the Project Cost dashboard page and select Duplicate Active Page. A new page 
appears in the dashboard. 

2. Right-click the new page and select Rename Page. The Rename Page dialog box opens. 

3. Type Project Time in the Title field. 

4. Click OK. 

Part 2: Add a document property for another drop-down control and use the same property for 
two of your visualizations 

1. Right-click the top-most Summarize By Text Area and select Edit Text Area. 

2. Right-click the drop-down control and select Edit Control. The Property Control dialog box 
opens. 

3. Click New. The New Property dialog box opens. 

4. Type Duration in the Property name field. 

5. Click OK. 

Note: All columns from the CLIENTPROJECT table are included automatically in the drop-down 
list in the Settings pane of the Property Control window. To limit the list, use the following 
expressions: PROJECTTYPE or USERNAME or ACCOUNT. Do not use ACCOUNTID. 

6. Click OK again. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/CreateAProjectTimeDashboard.mp4
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7. Right-click the text area and clear Edit Text Area. 

Part 3: Modify the page layout 

1. Right-click the Summarize By drop-down controls for the pie chart and cross table and select 
Close for each. 

2. Click-and-drag the cross-table visualization to the right of the bar chart. 

3. Right-click the bar chart and select Switch Visualization To > Treemap. 

4. Right-click the cross table and select Switch Visualization To > Scatter Plot. 

5. Right-click the pie chart and select Switch Visualization To > Combination Chart. 
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6. Right-click the treemap visualization and select Properties. 

7. Modify the following properties: 
 

Property Value 

General Type Average Project Cost by Duration in the Title field. 

Data Click New to create a new marking. Type Marking (2) in the Name field and 
then click OK. Select Marking (2) from the Marking drop-down list. No data 
limiting. 

Colors Right-click the Columns field and select Custom Expression. Remove the 
current expression. Type Avg in the Function field and double-click Avg. 
Double-click ACTUALCOST from the list of Available columns. Type Average 
Cost in the Display name field. Click OK. 

Colors Click Color Schemes > Document Color Schemes > Infor CRM. Select the 
Colors matched to values radio button. Click OK. 

Size Right-click the Size by field and then click Custom Expression. Remove the 
current expression. Type Avg in the Function field and double-click Avg. Clear 
the Function field, type Date, and double-click DateDiff. From the list of 
Available columns, double-click ENDDATE, type a comma, and double-click 
STARTDATE. Type Average Project Duration in the Display name field. Click 
OK. 

Hierarchy Right click the Hierarchy field and then click Set from Property. Click 
Duration. Click OK. 

Legend Clear all check boxes except Marking and Color by. Click OK. 

 

8. Click Close. 

9. Right-click the Scatter Plot visualization and select Properties. 
 

Property Value 

General Type Project Duration and Cost in the Title field. 

Data Select Marking (2) from the Marking drop-down list.  

X-Axis Right-click the Columns field and then click Custom Expression. Remove the 
current expression. Type Date in the Function field and double-click DateDiff. 
From the list of Available columns, double-click ENDDATE, type a comma, and 
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Property Value 

double-click STARTDATE. Type Average Project Duration in the Display name 
field. Click OK. 

Y-Axis Right-click the Columns field and then click Custom Expression. Remove the 
current expression. From the list of Available columns, double-click 
ACTUALCOST. Type Total Cost in the Display name field. Click OK. 

Colors Right-click the Columns field and then click Set from Property. Click 
Duration. Click OK. Click Color Schemes > Document Color Schemes > 
Infor CRM. Select the Colors only radio button. Click OK. 

Legend Select the Show legend check box. Clear all check boxes except for Marking 
and Color by.  

 

10. Click Close. 

11. Right-click the combination chart visualization and select Properties. 
 

Property Value 

General Type Number of Projects by Cost in the Title field. 

Data Select Marking (2) from the Marking drop-down list. 

X-Axis – 
Columns 

Right-click the Columns field and click Set from Property. Click Duration 
and click OK. Select the Show labels: Vertically radio button.  

Y-Axis – 
Columns 

Right-click the Columns field and click Custom Expression. Remove the 
current expression. Type Count in the Function field and double-click Count. 
From the list of Available Columns, double-click CLIENTPROJECTID. In the 
Expression field, type as [Projects]. Type Sum in the Function field and click 
Sum. From the list of Available columns, double-click ACTUALCOST, type 
as [Total Cost]. Click OK. Select the Multiple scales and For each color 
radio buttons. 
The end results should read: 
Count([CLIENTPROJECTID]) as [Projects], Sum{[ACTUALCOST]} as [Total 
Cost] 

Series From the Series by drop-down list, select (Column Names). Click Total Cost 
and select the Line radio button. 

Legend Select the Show legend check box and select the Series by and Marking 
check boxes. 
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12. Click Close. 

13. Select File > Save As > Library Item. The Save as Library Item window opens. 

14. Save as Projects and then click Finish. 

15. Click Yes to overwrite Projects. 

16. Click Close in the Save as Library Item window. 

When you mark anything in a treemap the corresponding values in the scatter plot and 
combination chart also display in the same marking color. You can mark inside the scatter plot or 
combination chart to see the corresponding colors marked in the treemap. This happens because 
they all share the same marking. 

 
For more design ideas, go to the TIBCO Spotfire Demo and Template Gallery at 
http://spotfire.tibco.com/demo/.  

 

Exercise 4.13: Capture bookmarks and set defaults 
In this exercise, you will create bookmarks to make it easier for dashboard users to toggle on 
and off a group of filters. 

• Add a bookmark for Cost Variance Low and Cost Variance High. 

• Capture defaults. 

Bookmarks are snapshots of the state of a dashboard which can be applied at any time. This 
allows the user to return to a previously created view of the data. Bookmarks can update one 
or more of the following: 

• Rows to mark 

• Page and visualization to be active 

• Filtering to apply 

http://spotfire.tibco.com/demo/
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One of the most important uses of bookmarks is to use them as links in a text area. This 
helps create guided analyses where the recipient of your analysis file can click action links to 
move through views of the analysis. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Open the Projects dashboard and view the Project Cost page. 

2. Type -100 and 7724.28 in the COSTVARIANCE field of the Filters pane.  

Note: Double-click the value to type. This field accepts actual values only. 

3. Clear the Include empty values check box. 

 
4. Select USERNAME from the Summarize By drop-down list in the bar chart’s Text Area. 

5. Select PROJECTTYPE from the Summarize By drop-down list in the pie chart’s Text Area. 

6. Select View > Bookmarks. The Bookmarks dialog box opens. 

7. Type Cost Variance Low in the Bookmarks field and then click Add Bookmark.  

The Cost Variance Low bookmark appears at the bottom of the Bookmarks dialog box. 

8. Type 7724.28 and 14401.00 in the COSTVARIANCE field of the Filters pane. 

9. Select View > Bookmarks. The Bookmarks dialog box opens. 

10. Type Cost Variance High in the Bookmarks field and click Add Bookmark.  

The Cost Variance High bookmark appears at the bottom of the Bookmarks dialog box. 

Part 2: Add quick links to these bookmarks in a text area 

1. Right-click the bar chart’s Text Area and select Edit Text Area. The editor toolbar opens. 

2. Add a couple spaces after the drop-down control. 

3. Click Insert Action Control. The Action Control window opens. 

 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/CaptureBookmarksAndDefaults.mp4
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4. Type Cost Variance Low in the Display text field. 

5. Select Link from the Control type drop-down list. 

6. Expand Bookmarks. 

7. Click Cost Variance Low in the Available actions pane. 

8. Click Add. 

9. Click OK. The bookmark link displays in the Text Area.  

10. Repeat steps 1 through 3. 

11. Type Cost Variance High in the Display text field. 

12. Select Link from the Control type drop-down list. 

13. Expand Bookmarks. 

14. Click Cost Variance High in the Available actions pane. 

15. Click Add. 

16. Click OK. 

17. Right-click the Text Area and then clear the Edit Text Area check box. 

Links are available for each bookmark now. Test each link to verify they work. 

 

Part 3: Set defaults for your dashboard.  

The selected settings in the dashboard design view will become your defaults when a user accesses the 
dashboard from Infor CRM. 

1. Click the Project Cost dashboard. 

2. Click Reset All Filters. 

 
3. Select PROJECTTYPE from the Summarize By drop-down list in the bar chart’s Text Area. 

4. Select USERNAME from the Summarize By drop-down list in the pie chart’s Text Area. 

5. Select USERNAME from the Summarize By drop-down list cross-table’s Text Area. 

6. Click File >Save As > Library Item. The Save as Library Item window opens. 

7. Type ClientProjects in the Name field and then click Finish. 

8. Click Yes to overwrite. 

9. Click Close. 
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Exercise 4.14: Apply security to a custom dashboard 
In this exercise, you will add security to custom dashboards where you don’t want other users 
to see data they don’t have access to. This is especially important if you have automatically 
scheduled updates. For example, since security has not been applied to your dashboard, 
signing in to Spotfire as admin whose default security only allows viewing for Everyone and 
Everyone – View Only accounts will still show project data for all accounts.  

By creating a new document property and creating a link to security information in your 
dashboard you can verify security is pulled by the user viewing the data 

Your instructor will demonstrate how to apply security to a dashboard so other user’s see 
only data he or she is allowed access. 

• Add a new document property and on-demand data table from security information 
link 

• Create new relationships between the data tables 

• Adjust filtering 

After completing this exercise, your result should look similar to the following: 
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The same dashboard shows different data per user. 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Add a new document property 

1. Open the Projects dashboard if it’s not already open. 

2. Select Edit > Document Properties. 

3. Click the Properties tab and then click New. The New Property window opens. 

4. Type LoadSecurity in the Name field. 

5. Verify String is selected in the Data type field. 

6. Type T in the Value field. 

 

When a user loads the dashboard document, Infor CRM runs a script to turn this 
property to T. If the property is already valued at T, the script values it to F and back 
to T to clear any data. You’ll leave it at T to view your data filter within the 
visualization as you design it. 

7. Click OK. 

 
8. Click OK again to close the Document Properties window. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/ApplySecurityToACustomDashboard.mp4
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Part 2: Add a new column to your information link.  

This column is from your Security model which holds your SECCODEID field. This column is used for 
security in Infor CRM. 

1. Select Insert > Columns. 

2. Select Projects from the Add Columns to data table drop-down list.  

Because this is the only data table in your analysis, it may already be selected. 

3. Select Information Link from the Select drop-down list in the Add Columns From field. 

4. Browse to Library and select Saleslogix > Model > Security Model > Security. 

5. Click OK. 

6. Expand the Show transformations (no transformation steps added) drop-down list and click 
Pivot. 

7. Click Add. The Pivot Data window opens. 

8. Select SECCODEID from the Row Identifiers drop-down field. 

9. Select SECCODEDESC from the Transfer Columns (%T) and aggregation methods (%A 
drop-down list. 

10. Type Security in the Transfer column naming pattern field. 

11. Click OK. 
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12. Click Next. The Insert Columns – Match Columns window opens. 

13. Select SECCODEID from the From Current Data drop-down list. 

14. Select SECCODEID from the From New Data list. 

15. Click Match Selected. 

16. Click Next. The Insert Columns – Import window opens. 

17. Select the Security check box in the Columns to add from new data pane. 

18. Select the Inner (rows matching in both current and new data only) check box. 

19. Click Finish. 

Part 3: Update the data table properties to verify data is reloaded when the dashboard loads 
instead of pulling cached data from your scheduled updates. 

1. Select Edit > Data Table Properties. 

2. Click the Scheduled Updates tab. 
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3. Select the Security check box in the Reload the following data for each user pane.  

Note: If a data table is unchecked, the scheduled updates are used. When a data table is 
checked, the data is reloaded. 

4. Click OK. 

5. Select File > Save. 

6. Click Yes to update the analysis in the library. 

Part 4: Hide these from other users 

1. Select Edit > Organize Filters. The Organize Filters window opens.  

2. Clear the Security check boxes. 

3. Click OK. 

4. Select File > Save As > Library Item. The Save as Library Item window opens.  

5. Save as Projects and then click Finish. 

6. Click Yes to overwrite Projects. 

7. Click Yes to keep previously associated bookmarks. 

8. Click Close when the save completes. 

 

Exercise 4.15: Add the Projects Dashboard to the Infor CRM Web client 
In this exercise, you will configure the Windows (Web) Client so users can launch custom 
dashboards from within the Windows (Web) Client. 

Add the dashboard set to Infor CRM Web Client. 

After completing this exercise, you should have the following result. 
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Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 

Part 1: Add the Project dashboard to Infor CRM Web client 

1. Open your browser and type localhost:3333/slxclient to open the Infor CRM Web Client. 

2. Type admin in the Username field.  

3. Type password in the Password field. 

4. Click Sign In. 

5. Select the Administration Nav Bar > Analytics Systems Info. 

6. Click Add Dashboard Path. The Add Dashboard Path window opens. 

7. Type ClientProjects in the Dashboard Name field. 

8. Type Client Projects in the Display Name field. 

9. Type Training/Analysis/ClientProjects in the Path field. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/AddADashboardToTheWebClient.mp4
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10. Click OK. 

11. Click Save. 

12. Press CTRL+F5 to refresh the browser.  

Part 2: Verify users have the Advanced Analytics roles and add a secured action for the 
dashboard 

1. Select the Administration Nav Bar > Users. 

2. Select all users by not selecting a user and clicking Add to Role from the User Tasks pane. The 
Select Role dialog box opens. 

3. Click Search. The Lookup Role dialog box opens. 

4. Click Advanced Analytics. 

5. Click OK twice. 

6. Click Save. 

7. Click the Administration Nav Bar. 

8. Right-click Secured Actions and select New Secured Action. 

9. Type AdvancedAnalytics/Dashboard/ClientProjects in the Name field. 

10. Click Save. 

11. Select the Advanced Analytics Nav Bar > Client Projects.  

The dashboard loads in Infor CRM. 

12. Click Sign Off. 

13. Click Return to sign in page. 

14. Type Lee in the Username field. No password required. 

15. Click Sign In. 

16. Select the Advanced Analytics Nav Bar > Client Projects. 

Part 3: Test the dashboard with a larger data set 

1. Click Sign off. 

2. Click Return to login page. 

3. Type Linda in the Username field. No password is required.  

4. Click Sign In. 

Linda sees a limited amount of data on the Client Projects dashboard compared to Lee 
indicating how security is working. 

 

Verify Linda is added to Spotfire as a user. If you added all users to the Advanced 
Analytics role, they will all be added to Spotfire automatically, but you must log on to 
Spotfire Professional Client to trigger the proper functionality. If Linda doesn’t have 
the Advanced Analytics role, refresh Spotfire Professional Client. 
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Exercise 4.16: Add a dashboard to the Windows client 
In this exercise, you will configure the Projects dashboard setting so users can launch it from 
within the Windows client. 

Add the dashboard set to Infor CRM Windows Client. 

After completing this exercise, you should have the following result: 

 

Notes: 

• If you are taking this course as classroom or virtual instructor-led training, observe as 
your instructor first demonstrates this exercise. 

• If you are taking this course as self-directed learning, complete the steps below. 

 

 Click here to view a demo and/or practice this task 

Exercise steps 
1. Select Start > All Programs > Infor CRM > Architect. 

2. Type admin in the Username field.  

3. Type password in the Password field.  

4. Click Sign In. The Open Project window opens. 

5. Click the Analytics Support project and then click Open. The Project Manager – Analytics 
Support window opens. 

https://campus2.infor.com/courses/CRM/v83/AdvancedAnalytics/AddADashboardToTheWindowsClient.mp4
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6. Double-click the (Toolbars System:Analytics Dashboard NavBar) plugin.  

A message opens indicating the plugin is Read Only. 

7. Click OK. 

8. Click the Advanced Analytics node in the Toolbar Strip window and select Add Child. 

9. Type ClientProjects Dashboard in the Toolbar Button field. 

10. Select After Previous from the Merge Rule drop-down list. 

11. Browse to C:\Program Files (x86)\Saleslogix in the Glyph field.  

Change the type of file to ICO and select the Reports.ico. 

Tip: You can also open the glyph from the Support dashboards item above and save the image 
for use on the Projects item. 

12. Select ActiveScript from the Action drop-down list. 

13. Type Personal:AnalyticsOpenProjectsDashboard in the Argument field. 

14. Type Client Projects Dashboard in the Hint field. 

 
15. Click Save. 

16. Leave the defaults and click OK. 
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17. Close the Toolbar Strip window. 

18. Double-click the (Scripts, VBscript System;AnalyticsOpenSupportDashboard) plugin in the 
Project Manager window. A message appears indicating the plugin is Read Only. 

19. Click OK. 

20. Press CTRL+A and CTRL+C to copy all contents of the script to your clipboard. 

21. Click Close. 

22. Select File > New Plugin > VB Script. 

23. Press CTRL+A and CTRL+V to replace all contents of the script with the code on your clipboard. 

24. Modify the sub Main to OpenDashboard “Project.” The code should look similar to the following: 

‘Including Script – System:Analytics Support  

option explicit  

sub Main  

  OpenDashboard “ClientProjects”  

end sub 

25. Click Include Additional Scripts from the toolbar in the Script window. 

26. Click Add Script. The Select Plugin to Open window opens. 

27. Expand System and then click Analytics Support. 

28. Click OK. 

29. Select File > Save. 

30. Leave the defaults and type AnalyticsOpenProjectsDashboard in the Name field. 

31. Click OK. 

32. Close the Script window. 

33. Click Release Plugins in the Project Manager window. The Release Plugins window opens. 

34. Select Everyone in the Plugin is release to pane. 

35. Click OK. 

36. Sign in to the Infor CRM Windows Client as Lee. 

37. Type Lee in the Username field. No password is required. 

38. Click Sign In. 

39. Select the Advanced Analytics Nav Bar > Client Projects Dashboard. Verify the dashboard 
loads and Lee has access to the project data for only accounts he has access to. 
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Customization best practices 

QA and production testing 
Follow the steps below when moving customizations between development, QA, and production 
environments: 

1. Verify each environment has the same version of Advanced Analytics installed. 

2. Using the Library Administration tool, export the Model folder of your customized folder structure. 
You can also export the Model folder of the Infor CRM folder structure assuming it was imported 
from production before developing.  

3. Move the exported models to the QA environment. 

4. Using the Library Administration tool, import the main and customized data models. Verify to 
select Replace Existing Item during the import process. 

5. Test the customization. When everything works as expected repeat the steps to move the 
exported models to the production environment and import. 

Upgrades 
Follow the steps below when upgrading a customized environment to a new version of Advanced 
Analytics: 

1. Use the Library Administration tool to export the main and customized data models to store it in a 
safe location in the QA environment. 

 

The customized data model and subfolders should not be changed by the upgrade; 
however, Infor CRM recommends that your company back them up. 

2. Import the new main data model folder(s) from the upgrade. Note: Currently, there is only an Infor 
CRM main data model folder. A future upgrade may have more. Verify to select Replace 
Existing Item during the import process.  

No further action is required now for updating columns in your customized folder; they remain 
unaffected by the upgrade.  

Alternatively, for any customized content in the Information Link and Analysis sub folders verify 
you review the following steps/options: 

Content copied from OOTB content: 

a. Option 1 (Light Customizations): Copy the new OOTB information links or analysis files to the 
appropriate customized sub folder and re-do the customizations. 

b. Option 2 (Heavy Customizations): Do not copy the new OOTB content. Instead, change the 
customized versions of the Information Link or Analysis files to reflect changes made in the 
OOTB data tables, information links, or analysis files. 

New content without copying OOTB content: 

a. Make any necessary changes so they continue to work as designed. For example, a 
customized dashboard may not have been based on an OOTB dashboard and instead on an 
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OOTB information link. Changes to the information link may require changes to the 
customized dashboard. 

3. When an upgrade completes use the export/import functions to move the model into a production 
environment. 
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Course summary 
Estimated time 
5 minutes 

Learning objectives 
Now that you have completed this course, you should be able to: 

• Install and configure working TIBCO Spotfire environment. 
• Install and configure Infor CRM Advanced Analytics to components. 
• Add data to Spotfire from a custom Infor CRM table. 
• Add data to Spotfire from a third-party table. 
• Create a parallel model for customization. 
• Design visualizations that limit data based on other visualizations. 
• Design visualizations that use custom expressions and bookmarks. 
• Apply Infor CRM security to a custom and dashboard. 
• Add a dashboard to Infor CRM Windows and Web. 

Topics 
• Course review 
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Appendices 
The following are included in this section: 

• Appendix A: Learner user accounts 
• Appendix B: Installing the Spotfire web player on a different computer from the Spotfire server 
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Appendix A: Learner user accounts 
Your instructor will assign you a student user ID from the table listed below to use for class exercises. 
Note: If you are taking this course as self-directed learning, refer to the Training Desktop Login 
Instructions on the Lab On Demand page. 
 

Infor CRM: Advanced Analytics v3.0/01_0610830_IEN0113_CRM 

Application User ID Username Password 

Administrator Administrator Admin <blank> 

Administrator Administrator Admin password 

Application Architect Administrator Admin password 

Infor CRM Web Client Administrator Admin <blank> 

Infor CRM Web Client Administrator Admin password 

Infor CRM Web Client Lee Hogan Lee <blank> 

Infor CRM Web Client Linda Walsh Linda <blank> 

Infor CRM Windows Client Lee Hogan Lee <blank> 

TIBCO Spotfire Professional Client Administrator Admin password 

 

 

 

 



 

100  Appendices 
  

 © 2018 Infor Education. All rights reserved. No part of this Training Workbook may be reproduced or transmitted in any form, without written permission. 

Appendix B: Installing the Spotfire web player on a 
different computer from the Spotfire server 
The following steps explain how to install the TIBCO Spotfire Web Player on a different computer from the 
Spotfire Server. 

To install 
1. If you have not already installed and configured the Spotfire Server do this step first. 

2. On the computer where the Spotfire Server installed, browse to the folder where the files were 
unzipped and find the SlxAASetup.log file. 

3. Copy the file to a convenient location on the destination computer where you will install the 
Spotfire Web Player. 

4. Browse to InforCRM_Advanced_Analytics_v3_0.zip and unzip the file to a convenient location on 
the destination computer. 

5. Browse to SLX Advanced Analytics Setup.exe and double-click to begin the installation. 

6. Click Load Settings on Step 1. 

7. Browse to the SlxAASetup.log file and click OK. 

The setup program populates using the settings on the server. Proceed to Step 3 which allows you 
to select Web Player install. 

8. Click Finish to install the Web Player and Client. 

Client installs on other computers doesn’t require or launch the additional steps added when 
installing the client on the same machine as the server. 

 

 

You are prompted for a Port Number when installing the Web Player. Use the following 
port number for the Web Player and not the port number already established for the 
server.  

The default is port 80, however, this port can cause conflicts. It’s recommended by Infor 
CRM that your company use port 8080 or 8088 instead. 
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